SUSE Support

Here When You Need Us

Listing of clients in SUSE Manager Server webUI results in "Request has timeout, please reload the page"

This document (000020868) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 4.2 Server
SUSE Manager 4.3 Server

Situation

When `Systems` is selected within the SUSE Manager webUI or when the menu is expanded and clicked on `All` (clients) the request times out after some time and no clients are listed.

Resolution

First it is recommended to increase the `rhn-search.java.maxmemory` parameter in `/etc/rhn/rhn.conf`. The default is 512MiB, increasing it to up to 4096MiB might help. 

If that does not help, try checking that `tomcat` is allowed to use enough memory. The parameter can be found in `/etc/sysconfig/tomcat`. Trying to increase the `-Xmx` parameter up to 8G may also help.

When none of above helps, another option is to perform a vacuum analyze of the database and re-index the tables that are likely to be impacted the most. Additional information provides details how to find out tables to re-index. 
> date && time spacewalk-sql --select-mode - <<< "vacuum ANALYZE;"
> date && time spacewalk-sql --select-mode - <<< "REINDEX table rhnPackage;"
> date && time spacewalk-sql --select-mode - <<< "REINDEX table rhnServerNeededCache;"
Important: Please note that the vacuum analyze could take some time to complete. Afterwards check if this improves loading time or ideally even resolves the issue.

It is also recommended to reduce number of items being listed within SUSE Manager Server webUI.

Cause

Performance issues in some specific SUSE Manager Server queries. 

Additional Information

When setting up the `tomcat` and `rhn.conf` options will not help, please proceed and open a support case and do the following steps, since this might be potentially caused by some query taking longer then it's supposed to.

Add the following line to `/var/lib/pgsql/data/postgresql.conf`:
log_min_duration_statement = 10000
Reload postgresql configuration by running the following command:
spacewalk-sql --select-mode - <<<"SELECT pg_reload_conf();"
Reproduce the problem

After the problem is reproduced, collect the following information and add this to the support case:
  • content of file '/var/lib/pgsql/data/postgresql.conf'
  • 3 or 4 more recent files from folder `/var/lib/pgsql/data/log/*.log`
  • or upload a new supportconfig

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020868
  • Creation Date: 21-Nov-2022
  • Modified Date:13-Dec-2022
    • SUSE Manager Server
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.