SUSE Support

Here When You Need Us

System in hang status due to lpfc FLOGI failure

This document (000021054) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server for SAP Applications 15 all versions
SUSE Linux Enterprise Server 15 all versions

Situation

The system was in a hang status and not accepting ssh connection. Rebooting it through the console and it hung again after a few days. This issue repeated two times.
 

Resolution

Contact the hardware vendor to check the status of the HBA adapter and the link. The issue was fixed after replacing the target HBA adapter.
 

Cause

This is a hardware issue. The logs were showing an issue related to the HBA; the link is flapping too much and it failed to access the storage/disks “FLOGI”.
kernel: [166638.670177] lpfc: 3:(0):2858 FLOGI failure Status:x3/x103 TMO:x14 Data 
kernel: [166639.387168] lpfc: 3:1303 Link Up Event x357 received Data: 
kernel: [166640.481405] lpfc: 3:1305 Link Down Event x358 received Data: 

The last reported logs before rebooting were related to the HBA.
kernel: [166989.695217] lpfc 0000:66:00.1: 167: [166989.695146] 3:0357 ELS CQE error: status=x3: CQE: 
kernel: [166989.695219] lpfc 0000:66:00.1: 168: [166989.695156] 3:0328 Rsp Ring 2 error: IOCB Data: 
kernel: [166989.695221] lpfc 0000:66:00.1: 3:(0):2858 FLOGI failure Status:x3/x103 
.
.
.
.
systemd-tmpfiles[5434]: [/usr/lib/tmpfiles.d/net-snmp.conf:1] Line references path below legacy directory /var/run/, updating /var/run/net-snmp → /run/net-snmp; please update the tmpfiles.d/ drop-in file accordingl

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021054
  • Creation Date: 27-Apr-2023
  • Modified Date:27-Apr-2023
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.