SUSE Support

Here When You Need Us

booting ends in grub command line with btrfs filesystem for root

This document (000021092) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 all service packs
SUSE Linux Enterprise Server 12 all service packs



 

Situation

Upon booting the server ends up in grub command line:
grub>
 

Resolution

Boot from the installation ISO into the rescue mode.
Example on how to mount the btrfs filesystem and check it's contents:
#lsblk -f
#mount /dev/mapper/system-root /mnt
#btrfs subvolume list /mnt
#umount /mnt
#mount -o subvol=@ /dev/mapper/system-root /mnt

Check the default subvolume:

#btrfs subvolume get-default /mnt

It was found in some cases that the default subvolume was incorrectly set for some reason or was missing the important files.
In such cases this can fixed by pointing the default subvolume to the latest correct snapshot (has grub.cfg, kernel etc.).

For example (you need to replace 273 with the ID on your system):

#btrfs subvolume list
..
ID 273 gen 194 top level 266 path @/.snapshots/4/snapshot
#btrfs subvolume set-default 273 /mnt

 

Cause

For btrfs filesystem grub tries to boot from the default subvolume. If this subvolume does not contain the grub.cfg configuration file then you end up in grub command line.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021092
  • Creation Date: 06-Jun-2023
  • Modified Date:16-Jun-2023
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.