SUSE Support

Here When You Need Us

Installation on zEC12 with YaST2 and VNC causes Ruby core dump

This document (000021480) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP5
 

Situation

Only in effect on SUSE Linux Enterprise for IBM zSeries - zEC12

Attempting to install SLES15 SP5 with VNC causes a ruby2.5 core dump.
The following error is displayed on the console:
[...]
starting VNC server...                                                          
A log file will be written to: /var/log/YaST2/vncserver.log ...                 
                                                                                
***                                                                             
***           You can connect to , display :1 now with vncviewer          
***           Or use a Java capable browser on http://:5801/              
***                                                                             
(When YaST2 is finished, close your VNC viewer and return to this window.)      
                                                                                
Active interfaces:                                                              
                                                                                
eth0: 02:00:00:00:00:29                                                         
  x.xx.xx.  xxx/22                                                                
  xxxx::xxx:x:xxx:xx/64                                                       
                                                                                
*** Starting YaST ***                                                           
/usr/lib/YaST2/startup/YaST2.call: line 454:  3403 Aborted  (core 
 dumped) $OPT_FBITERM "$Y2START" $Y2START_ARGS                                


YaST output in the ./log/YaST2/y2log when aborting:
<date> <time> <2> s390<username>(3403) [qt-ui] YQUI.cc(qMessageHandler):656
 QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
<date> <time> <1> s390<username>(3403) [qt-styler] QY2Styler.cc(loadStyleSheet):158 Using style sheet "/usr/share/YaST2/theme/current/wizard/installation.

Also in the ./log/YaST2/y2log:
 
<time> <1> [Ruby] bin/y2start():22 y2base called with ["widget_demo", "qt", "-name", "YaST2", "-icon", "yast"] 
<time> <1> [ui-component] YUIComponentCreator.cc(createInternal):124 Creating UI component for "" 
<time> <1> [ui] YUI.cc(YUI):83 This is libyui 4.5.3 
<time> <1> [ui] YUI.cc(YUI):84 Creating UI with threads 
<time> <1> [qt-ui] YQUI.cc(YQUI):110 This is libyui-qt 4.5.3 
<time> <1> [qt-ui] YQUI.cc(qMessageHandler):647  Could not load the Qt platform plugin "xcb" in "" even though it was found. 
<time> <3> [qt-ui] YQUI.cc(qMessageHandler):660 This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
<time> <3> [qt-ui] YQUI.cc(qMessageHandler):660 
<time> <3> [qt-ui] YQUI.cc(qMessageHandler):660 Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb. 
<time> <3> [qt-ui] YQUI.cc(qMessageHandler):660

Resolution

The issue was reported to engineering and at time of writing it's unclear whether and when a patch will be made available. 
The hardware is End of life (EOL) and End of Service live (EOSL).

It doesn't happen with the NCurses UI (text mode).
In case an installation on EOL hardware will be necessary, ssh without X can be used as workaround.

Cause

The pcre12 package is missing assembler instructions probably existing only on EC12.
 

Status

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021480
  • Creation Date: 01-Jul-2024
  • Modified Date:01-Aug-2024
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.