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Issues Enabling LTSS in Public Cloud

This document (000021678) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12

SUSE Linux Enterprise Server 15

Public Cloud


Situation

When registering LTSS using registercloudguest command, customer may experience multiple issues:

  1. When running the following command: registercloudguest -r LTSS_REGISTRATION_CODE, the logfile /var/log/cloudregister.log shows the following message: Non free extension SLES-LTSS/12.5/x86_64 failed to be removed which will prevent any repositories from being available
  2. After registering an instance with LTSS, any zypper command will return a "Permission to Access" message.

Resolution

For situation #1, the following commands must be run in order to fix:

zypper rm sles-ltss-release-POOL sles-ltss-release
registercloudguest
registercloudguest -r LTSS_REGISTRATION_CODE

 

For situation #2, the following commands must be run to get access again to repositories:

zypper refresh --force
zypper refresh --force

(This same command must be run twice)

Cause

There are multiple bugs open for this issue.  This is a server side issue and engineering are working on a fix. The updated server code is in final testing before it gets submitted to the maintenance process. Once released the fixes will be released to the update infrastructure.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021678
  • Creation Date: 23-Jan-2025
  • Modified Date:23-Jan-2025
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

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