SUSE Support

Here When You Need Us

ls: cannot access '/usr/lib64/jvm/*': No such file or directory

This document (7023474) is provided subject to the disclaimer at the end of this document.

Environment


SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)
SUSE Linux Enterprise Server 12 Service Pack 3 (SLES 12 SP3)

Situation

Login (ssh or su -) to a system as user who's login shell is /usr/bin/csh or /usr/bin/tcsh will result in the output:
ls: cannot access '/usr/lib64/jvm/*': No such file or directory

For example:

# ssh foo@<xx.xx.xx.xx> Password: Last login: Mon Oct 22 11:54:45 2018 from xx.xx.xx.x ls: cannot access '/usr/lib64/jvm/*': No such file or directory linux-kvph /home/foo%

Resolution

As a workaround create an empty file in /usr/lib64/jvm.

On SLES12 SP2 a future aaa_base update will include the patch to resolve the problem.

The SLES12 SP3 aaa_base update, aaa_base-13.2+git20140911.61c1681-38.13.1 released November 2018 includes the patch to resolve the problem.

On SLES15 (SUSE Linux Enterprise Module for Basesystem 15) the aaa_base update, aaa_base-84.87+git20180409.04c9dae-3.3.2 released October 2018 includes the patch to resolve the issue.

Cause

The assumed error is just a message not causing any harm.
The installation of javapackages-tools created an empty /usr/lib64/jvm. The 'ls' command for java paths in /etc/profile.d/alljava.(t)csh is not able to redirect only stderr, so the user sees the message that is suppressed in other shells like bash.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023474
  • Creation Date: 25-Oct-2018
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.