SUSE Support

Here When You Need Us

Pacemaker controlled network interface reports label error exceeding 15 characters

This document (7023808) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability Extension 12

Situation

A cluster managed network interface controlled by the IPaddr2 resource agent reports the specified interface label would exceed the allowed limit of 15 characters:

2019-04-05T13:48:10.596570+02:00 sles12cluster1 IPaddr2(admin_addr)[5003]: ERROR: Interface label [eth0:testtesttest] exceeds maximum character limit of 15
2019-04-05T13:48:10.602892+02:00 sles12cluster1 lrmd[1281]:   notice: admin_addr_monitor_10000:5003:stderr [ ocf-exit-reason:Interface label [eth0:testtesttest] exceeds maximum character limit of 15 ]
2019-04-05T13:48:10.633053+02:00 sles12cluster1 crmd[1284]:   notice: sles12cluster1-admin_addr_monitor_10000:149 [ ocf-exit-reason:Interface label [eth0:testtesttest] exceeds maximum character limit of 15\n ]


Resolution

From /usr/lib/ocf/resource.d/heartbeat/IPaddr2:

[...]
The kernel allows alphanumeric labels up to a maximum length of 15
characters including the interface name and colon (e.g. eth0:foobar1234)
[...]

Hence the total number of characters must not exceed 15 characters.

Cause

The total number of characters for devicename, colon and iflabel (e.g. vlanXXXX:somelabel) was exceeded.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023808
  • Creation Date: 05-Apr-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise High Availability Extension

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.