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SUMA Client Patch Status (WebUI and CLI) is Not in Sync

This document (000020572) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 4.3

SUSE Linux Enterprise Server for SAP Applications 12 SP5


Situation

SUSE Manager SLES-SAP client(s) shows a different patch status, the webUI indicates there are patches available to be installed, while the client command line indicates no new updates are available.

Resolution

Re-generate the yum cache for the affected channels from the SUMA command line (replace the '*' with the name of the actual channels in use on the affected client).

1.  List all the channels that are assigned to the affected client:

# spacecmd system_details <name_of_the_client>

2.  Re-generate the yum cache for the channels:

# spacecmd -u <admin> --debug -- softwarechannel_regenerateyumcache -f '*'

For example:

# spacecmd -u sadmin --debug -- softwarechannel_regenerateyumcache -f 'sles12sp5-sap-sandbox-SLE12-SP5-SAP-Pool for x86_64'

3.  At least for the affected client run package refresh, in the webUI: Systems > Select the relevant system > Software > "Update Package List".

Cause

Abnormal communication between the SUSE Manager server and the client can cause the issue. Note that removing and registering the client again may in some cases also resolve this issue. 

Additional Information

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020572
  • Creation Date: 31-Jan-2022
  • Modified Date:12-Nov-2024
    • SUSE Linux Enterprise Server for SAP Applications
    • SUSE Manager Server
    • SUSE Manager Proxy

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