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SUSEConnect registration system failed : x509: certificate has expired or is not yet valid

This document (000021135) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 all SP
SUSE Linux Enterprise Server 12 all SP
SUSE Linux Enterprise Server for SAP Applications 15 all SP
SUSE Linux Enterprise Server for SAP Applications 12 all SP

Situation

The system fails to register to the SUSE Customer Center:
# SUSEConnect -r XXXXXXXXXXX
Registering system to SUSE Customer Center

Announcing system to https://scc.suse.com ...
SUSEConnect error: Post "https://scc.suse.com/connect/subscriptions/systems": x509: certificate has expired or is not yet valid: current time 2023-05-16T23:17:07+08:00 is before 2023-06-12T00:00:00Z

Resolution

1. Use the YaST Clock and Timezone module to manually configure the correct ntp server on the client system to ensure the system time is accurate, or to manually adjust the system time to reduce the time difference:
# yast timezone -> [Other Settings...]

2. Or use the timedatectl command to manually adjust the system time to reduce the time difference:
# timedatectl set-time "YYYY-MM-DD HH:MM:SS"

Cause

The client system's date and/or time are incorrect, and there is a large date/time difference with SCC.

Status

Top Issue

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021135
  • Creation Date: 13-Jul-2023
  • Modified Date:19-Jul-2023
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

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