SUSE Support

Here When You Need Us

corosync:[TOTEM] Digest does not match

This document (000020368) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server for SAP 15 
SUSE Linux Enterprise Server for SAP 12

Situation

In one two-node cluster, The following can be seen while checking the coroysync service status, and the same error is also filling the messages log file.

corosync[]:[TOTEM] Digest does not match
corosync[]:[TOTEM] Received message has invalid digest... ignoring.
corosync[]:[TOTEM] Invalid packet data

Resolution

To solve the issue perform the following actions:

  1. Check if the /etc/corosync/corosync.conf and the /etc/corosync/authkey files are synchronized between the two nodes. For example with md5sum, files size, and also the permission mode of authkey file. The output of the md5 check should be the same on both nodes. 
  2. Check if the “transport” option is inside the totem section in the file /etc/corosync/corosync.conf for both cluster nodes. If it is outside, then modify it to be inside and stop/start the pacemaker service.

Example(“transport” option is inside the totem section):

totem {
        version: 2
        secauth: on
        crypto_hash: sha1
        crypto_cipher: aes256
        cluster_name: hacluster
        clear_node_high_bit: yes
        token: 5000
        token_retransmits_before_loss_const: 10
        join: 60
        consensus: 6000
        max_messages: 20
        interface {
                ringnumber: 0
                mcastport: 5405
                ttl: 1
        }

        transport: udpu
}

Cause

If the transport option is placed outside the totem stanza (where it belongs). This means that it is simply ignored and so corosync reverts back to the default behaviour, which is to use multicast.
To compound the issue, some clusters have the same mcastaddr directive. Two clusters configured in this way would therefore be justified in believing they are a single cluster because they are in the same multicast group. They would then attempt to merge together.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020368
  • Creation Date: 26-Aug-2021
  • Modified Date:02-Sep-2021
    • SUSE Linux Enterprise High Availability Extension
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.