SUSE Support

Here When You Need Us

The screen is showing three question marks "???" during boot

This document (000021298) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP5

Situation

Booting a server with 2 CPUs in UEFI mode the screen shows three question marks: "???" and three dots, for a couple of seconds, before switching to the login screen.
 

Resolution

Add a delay to plymouth to wait a little longer before starting.

1. Increase, edit the DeviceTimeout in the file /etc/plymouth/plymouthd.conf
The exact value depends on the actual situation/hardware, generally 30 is enough.

If the file doesn't exist, create the /etc/plymouth/plymouthd.conf and copy the below content into the file:
[Daemon]
Theme=SLE
ShowDelay=0
DeviceTimeout=30
For an easy method writing the file on the CLI see "Additional Information".

2. Run "dracut -qf" to regenerate the initrd
3. Reboot

Cause

The question marks and three points are plymouth's fallback theme.
This happens when plymouth meets an abnormal condition, eg: plymouth can't find a display device until it's timeout value (DeviceTimeout) so plymouth is using it's fall-back theme, based on text display, console based output.
In this case, the condition is caused by the kernel and the SLES15 SP5's graphic device not being initialized during the pre-defined timeout value.
Instead changing the timing on the kernel side, we configure plymouth to wait longer by increasing the DeviceTimeout.

Additional Information

If /etc/plymouth/plymouthd.conf doesn't exist it can be created on the terminal like this:
 
# cat << EOF > /etc/plymouth/plymouthd.conf 
[Daemon]
Theme=SLE
ShowDelay=0
DeviceTimeout=30
EOF

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021298
  • Creation Date: 19-Dec-2023
  • Modified Date:21-Dec-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.